Thursday 30 June 2016

Creating & extending a file system with HP-UX LVM

Step 1: Scan the disk & make it visible on the server

#insf -e (create device files for any newly added devices)
#ioscan -fnC disk

Step 2: Create a physical volume

#diskinfo /dev/rdisk/disk210 (check disk size)
#pvcreate /dev/disk/disk210

Step 3: Create the volume group

#mkdir /dev/vgignite
#ll /dev/*/group (check for currently create group special device files)
#mknod /dev/vgignite/group c 128 0x010000 (create new group device special file specifying the major & minor numbers as 128 &0x010000 )

The major number signifies the type of device file & minor number will uniquely identify the device.

#vgcreate -V 2.0 -s 64 -S 4t /dev/vgignite /dev/disk/disk210

Step 4: Create a logical volume

#lvcreate -L 256000 -n lv_ignite -s y /dev/vgignite (size is in MB)
#lvdisplay /dev/vgignite/lv_ignite

Step 5: Create & mount the file system

#newfs -F vxfs -o largefiles /dev/vgignite/rlv_ignite
#mount /dev/vgignite/lv_ignite /ignite_depot


To extend the file system:

Step 1: Extend the logical volume:

#lvextned -L 512000 -n lv_ignite /dev/vgignite (size is in MB)

Step 2: Extend the file system:

#fsadm -F vxfs -b 512000M  /ignite_depot

No comments:

Post a Comment

Using capture groups in grep in Linux

Introduction Let me start by saying that this article isn't about capture groups in grep per se. What we are going to do here with gr...